import Foundation
let pattern = #"^\W?1.*(\d{3}).*(\d{3}).*(\d{4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
19999999999
+19999999999
1-999-999-9999
1-(999) 999-9999
238934265981239
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1($1) $2-$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)