package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\W?1.*(\d{3}).*(\d{3}).*(\d{4})$`)
var str = `19999999999
+19999999999
1-999-999-9999
1-(999) 999-9999
238934265981239`
var substitution = "1($1) $2-$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}