// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\W?1.*(\d{3}).*(\d{3}).*(\d{4})$").unwrap();
let string = "19999999999
+19999999999
1-999-999-9999
1-(999) 999-9999
238934265981239";
let substitution = "1($1) $2-$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}