use strict;
my $str = '19999999999
+19999999999
1-999-999-9999
1-(999) 999-9999
238934265981239';
my $regex = qr/^\W?1.*(\d{3}).*(\d{3}).*(\d{4})$/mp;
my $subst = '1($1) $2-$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";