using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\W?1.*(\d{3}).*(\d{3}).*(\d{4})$";
string substitution = @"1($1) $2-$3";
string input = @"19999999999
+19999999999
1-999-999-9999
1-(999) 999-9999
238934265981239";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}