#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.+[a-z])([0-9]+)([a-z].+)"
Local $sString = "aaaaaaa0aaa" & @CRLF & _
"bbbbbbb0bbbbbb" & @CRLF & _
"cccccc 2.0"
Local $sSubst = "$1x$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)