$re = '/(.+[a-z])([0-9]+)([a-z].+)/m';
$str = 'aaaaaaa0aaa
bbbbbbb0bbbbbb
cccccc 2.0';
$subst = "$1x$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;