const regex = /(.+[a-z])([0-9]+)([a-z].+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+[a-z])([0-9]+)([a-z].+)', 'gm')
const str = `aaaaaaa0aaa
bbbbbbb0bbbbbb
cccccc 2.0`;
const subst = `$1x$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);