// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.+[a-z])([0-9]+)([a-z].+)").unwrap();
let string = "aaaaaaa0aaa
bbbbbbb0bbbbbb
cccccc 2.0";
let substitution = "$1x$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}