re = /(.+[a-z])([0-9]+)([a-z].+)/m
str = 'aaaaaaa0aaa
bbbbbbb0bbbbbb
cccccc 2.0'
subst = '$1x$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result