import Foundation
let pattern = #"(.+[a-z])([0-9]+)([a-z].+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
aaaaaaa0aaa
bbbbbbb0bbbbbb
cccccc 2.0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1x$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)