use strict;
my $str = 'aaaaaaa0aaa
bbbbbbb0bbbbbb
cccccc 2.0';
my $regex = qr/(.+[a-z])([0-9]+)([a-z].+)/mp;
my $subst = '$1x$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";