package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+[a-z])([0-9]+)([a-z].+)`)
var str = `aaaaaaa0aaa
bbbbbbb0bbbbbb
cccccc 2.0`
var substitution = "$1x$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}