package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(location \/api.*?proxy_pass\s*)([^ ;]+)`)
var str = `server {
listen 80;
server_name localhost;
location /api {
rewrite /api/(.*) /$1 break;
proxy_pass https://host.name:1337;
proxy_redirect off;
proxy_set_header Host $host;
}
location / {
root /usr/share/nginx/html;
index index.html index.htm;
}
}`
var substitution = "$1http://localhost:1234"
fmt.Println(re.ReplaceAllString(str, substitution))
}