const regex = /(location \/api.*?proxy_pass\s*)([^ ;]+)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(location \\\/api.*?proxy_pass\\s*)([^ ;]+)', 'gms')
const str = `server {
listen 80;
server_name localhost;
location /api {
rewrite /api/(.*) /\$1 break;
proxy_pass https://host.name:1337;
proxy_redirect off;
proxy_set_header Host \$host;
}
location / {
root /usr/share/nginx/html;
index index.html index.htm;
}
}`;
const subst = `$1http://localhost:1234`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);