import Foundation
let pattern = #"(location \/api.*?proxy_pass\s*)([^ ;]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
server {
listen 80;
server_name localhost;
location /api {
rewrite /api/(.*) /$1 break;
proxy_pass https://host.name:1337;
proxy_redirect off;
proxy_set_header Host $host;
}
location / {
root /usr/share/nginx/html;
index index.html index.htm;
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1http://localhost:1234"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)