$re = '/(location \/api.*?proxy_pass\s*)([^ ;]+)/ms';
$str = 'server {
listen 80;
server_name localhost;
location /api {
rewrite /api/(.*) /$1 break;
proxy_pass https://host.name:1337;
proxy_redirect off;
proxy_set_header Host $host;
}
location / {
root /usr/share/nginx/html;
index index.html index.htm;
}
}';
$subst = "$1http://localhost:1234";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;