#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:\[|(?!^)\G)[^]\s]*)\s"
Local $sString = " [City tier] [nvarchar](max) NULL," & @CRLF & _
" [Counting unit] [nvarchar](max) NULL,"
Local $sSubst = "$1_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)