re = /((?:\[|(?!^)\G)[^]\s]*)\s/m
str = ' [City tier] [nvarchar](max) NULL,
[Counting unit] [nvarchar](max) NULL,'
subst = '$1_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result