$re = '/((?:\[|(?!^)\G)[^]\s]*)\s/m';
$str = ' [City tier] [nvarchar](max) NULL,
[Counting unit] [nvarchar](max) NULL,';
$subst = "$1_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;