import Foundation
let pattern = #"((?:\[|(?!^)\G)[^]\s]*)\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[City tier] [nvarchar](max) NULL,
[Counting unit] [nvarchar](max) NULL,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)