#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*?)\.(wordX\..*)\. (.*)\."
Local $sString = "TITLE.wordX. aaa.: AAAAAAA;AAAAA. BBBB: bbbb." & @CRLF & _
""
Local $sSubst = "$1 - $2 - $3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)