re = /^(.*?)\.(wordX\..*)\. (.*)\./m
str = 'TITLE.wordX. aaa.: AAAAAAA;AAAAA. BBBB: bbbb.
'
subst = '$1 - $2 - $3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result