import re
regex = re.compile(r"^(.*?)\.(wordX\..*)\. (.*)\.", flags=re.MULTILINE)
test_str = ("TITLE.wordX. aaa.: AAAAAAA;AAAAA. BBBB: bbbb.\n")
subst = "$1 - $2 - $3"
result = regex.sub(subst, test_str)
if result:
print(result)