$re = '/^(.*?)\.(wordX\..*)\. (.*)\./m';
$str = 'TITLE.wordX. aaa.: AAAAAAA;AAAAA. BBBB: bbbb.
';
$subst = "$1 - $2 - $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;