const regex = /^(.*?)\.(wordX\..*)\. (.*)\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)\\.(wordX\\..*)\\. (.*)\\.', 'gm')
const str = `TITLE.wordX. aaa.: AAAAAAA;AAAAA. BBBB: bbbb.
`;
const subst = `$1 - $2 - $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);