using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_balance"":([1-9]\d*\.?\d*|\d\.\d*[1-9]\d*)";
string input = @"_balance"":0
_balance"":7
_balance"":75
_balance"":0.
_balance"":0.1
_balance"":5.25
_balance"":0.0
_balance"":0.001
_balance"":0.00010";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}