re = /_balance":([1-9]\d*\.?\d*|\d\.\d*[1-9]\d*)/m
str = '_balance":0
_balance":7
_balance":75
_balance":0.
_balance":0.1
_balance":5.25
_balance":0.0
_balance":0.001
_balance":0.00010'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end