import re
regex = re.compile(r"_balance\":([1-9]\d*\.?\d*|\d\.\d*[1-9]\d*)", flags=re.MULTILINE)
test_str = ("_balance\":0 \n"
"_balance\":7\n"
"_balance\":75\n"
"_balance\":0.\n"
"_balance\":0.1\n"
"_balance\":5.25\n"
"_balance\":0.0\n"
"_balance\":0.001\n"
"_balance\":0.00010")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")