import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_balance\":([1-9]\\d*\\.?\\d*|\\d\\.\\d*[1-9]\\d*)";
final String string = "_balance\":0 \n"
+ "_balance\":7\n"
+ "_balance\":75\n"
+ "_balance\":0.\n"
+ "_balance\":0.1\n"
+ "_balance\":5.25\n"
+ "_balance\":0.0\n"
+ "_balance\":0.001\n"
+ "_balance\":0.00010";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}