$re = '/_balance":([1-9]\d*\.?\d*|\d\.\d*[1-9]\d*)/m';
$str = '_balance":0
_balance":7
_balance":75
_balance":0.
_balance":0.1
_balance":5.25
_balance":0.0
_balance":0.001
_balance":0.00010';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);