const regex = /_balance":([1-9]\d*\.?\d*|\d\.\d*[1-9]\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_balance":([1-9]\\d*\\.?\\d*|\\d\\.\\d*[1-9]\\d*)', 'gm')
const str = `_balance":0
_balance":7
_balance":75
_balance":0.
_balance":0.1
_balance":5.25
_balance":0.0
_balance":0.001
_balance":0.00010`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}