package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+(https?.+?)(<|\s)`)
var str = `<h1>Hello</h1>
Visit this link: http://www.link1.com<br />
Visit this link: http://www.link1.com <br />
Visit this link: http://www.link1.com/some_other_words <br />
And <strong>this</strong>:
<a href="http://www.link2.com">http://www.link2.com</a>`
var substitution = " <a href="$1">$1</a>$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}