const regex = /\s+(https?.+?)(<|\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+(https?.+?)(<|\\s)', 'gm')
const str = `<h1>Hello</h1>
Visit this link: http://www.link1.com<br />
Visit this link: http://www.link1.com <br />
Visit this link: http://www.link1.com/some_other_words <br />
And <strong>this</strong>:
<a href="http://www.link2.com">http://www.link2.com</a>`;
const subst = ` <a href="$1">$1</a>$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);