use strict;
my $str = '<h1>Hello</h1>
Visit this link: http://www.link1.com<br />
Visit this link: http://www.link1.com <br />
Visit this link: http://www.link1.com/some_other_words <br />
And <strong>this</strong>:
<a href="http://www.link2.com">http://www.link2.com</a>';
my $regex = qr/\s+(https?.+?)(<|\s)/mp;
my $subst = ' <a href="$1">$1</a>$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";