re = /\s+(https?.+?)(<|\s)/m
str = '<h1>Hello</h1>
Visit this link: http://www.link1.com<br />
Visit this link: http://www.link1.com <br />
Visit this link: http://www.link1.com/some_other_words <br />
And <strong>this</strong>:
<a href="http://www.link2.com">http://www.link2.com</a>'
subst = ' <a href="$1">$1</a>$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result