import re
regex = re.compile(r"\s+(https?.+?)(<|\s)", flags=re.MULTILINE)
test_str = ("<h1>Hello</h1>\n"
"Visit this link: http://www.link1.com<br />\n"
"Visit this link: http://www.link1.com <br />\n"
"Visit this link: http://www.link1.com/some_other_words <br />\n"
"And <strong>this</strong>: \n"
"<a href=\"http://www.link2.com\">http://www.link2.com</a>")
subst = " <a href=\"$1\">$1</a>$2"
result = regex.sub(subst, test_str)
if result:
print(result)