import Foundation
let pattern = #"\s+(https?.+?)(<|\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<h1>Hello</h1>
Visit this link: http://www.link1.com<br />
Visit this link: http://www.link1.com <br />
Visit this link: http://www.link1.com/some_other_words <br />
And <strong>this</strong>:
<a href="http://www.link2.com">http://www.link2.com</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" <a href="$1">$1</a>$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)