using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@Template\(""(.[^\(\:]*)?(?:\:)(.[^\(\:]*)?(?:\:)?(.[^\(\:]*)?""\)";
string substitution = @"@Template\(""$1/$2/$3";
string input = @"@Template(""Area:Local:delete.html.twig"")
@Template(""Group:add.html.twig"")
@Templaty(""Group:add.html.twig"")";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}