use strict;
my $str = '@Template("Area:Local:delete.html.twig")
@Template("Group:add.html.twig")
@Templaty("Group:add.html.twig")';
my $regex = qr/@Template\("(.[^\(\:]*)?(?:\:)(.[^\(\:]*)?(?:\:)?(.[^\(\:]*)?"\)/p;
my $subst = '@Template\\("$1/$2/$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";