$re = '/@Template\("(.[^\(\:]*)?(?:\:)(.[^\(\:]*)?(?:\:)?(.[^\(\:]*)?"\)/';
$str = '@Template("Area:Local:delete.html.twig")
@Template("Group:add.html.twig")
@Templaty("Group:add.html.twig")';
$subst = "@Template\(\"$1/$2/$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;