import re
regex = re.compile(r"@Template\(\"(.[^\(\:]*)?(?:\:)(.[^\(\:]*)?(?:\:)?(.[^\(\:]*)?\"\)")
test_str = ("@Template(\"Area:Local:delete.html.twig\")\n"
"@Template(\"Group:add.html.twig\")\n"
"@Templaty(\"Group:add.html.twig\")")
subst = "@Template\\(\"$1/$2/$3"
result = regex.sub(subst, test_str)
if result:
print(result)