const regex = /@Template\("(.[^\(\:]*)?(?:\:)(.[^\(\:]*)?(?:\:)?(.[^\(\:]*)?"\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@Template\\("(.[^\\(\\:]*)?(?:\\:)(.[^\\(\\:]*)?(?:\\:)?(.[^\\(\\:]*)?"\\)', 'g')
const str = `@Template("Area:Local:delete.html.twig")
@Template("Group:add.html.twig")
@Templaty("Group:add.html.twig")`;
const subst = `@Template\("$1/$2/$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);