re = /@Template\("(.[^\(\:]*)?(?:\:)(.[^\(\:]*)?(?:\:)?(.[^\(\:]*)?"\)/
str = '@Template("Area:Local:delete.html.twig")
@Template("Group:add.html.twig")
@Templaty("Group:add.html.twig")'
subst = '@Template\\("$1/$2/$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result