// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"@Template\("(.[^\(\:]*)?(?:\:)(.[^\(\:]*)?(?:\:)?(.[^\(\:]*)?"\)"#).unwrap();
let string = "@Template(\"Area:Local:delete.html.twig\")
@Template(\"Group:add.html.twig\")
@Templaty(\"Group:add.html.twig\")";
let substitution = "@Template\\(\"$1/$2/$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}