# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+)\R(?:\1(?:\R|$))+//gm;t' <<< "192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.2
192.168.0.3
192.168.0.3
192.168.0.4
192.168.0.5
192.168.0.5
192.168.0.6"