# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.+)\R(?:\1(?:\R|$))+"
test_str = ("192.168.0.1\n"
"192.168.0.1\n"
"192.168.0.1\n"
"192.168.0.1\n"
"192.168.0.2\n"
"192.168.0.3\n"
"192.168.0.3\n"
"192.168.0.4\n"
"192.168.0.5\n"
"192.168.0.5\n"
"192.168.0.6")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.