use strict;
my $str = '192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.2
192.168.0.3
192.168.0.3
192.168.0.4
192.168.0.5
192.168.0.5
192.168.0.6';
my $regex = qr/^(.+)\R(?:\1(?:\R|$))+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";