import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+)\\R(?:\\1(?:\\R|$))+";
final String string = "192.168.0.1\n"
+ "192.168.0.1\n"
+ "192.168.0.1\n"
+ "192.168.0.1\n"
+ "192.168.0.2\n"
+ "192.168.0.3\n"
+ "192.168.0.3\n"
+ "192.168.0.4\n"
+ "192.168.0.5\n"
+ "192.168.0.5\n"
+ "192.168.0.6";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}