const regex = /^(.+)\R(?:\1(?:\R|$))+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+)\\R(?:\\1(?:\\R|$))+', 'gm')
const str = `192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.2
192.168.0.3
192.168.0.3
192.168.0.4
192.168.0.5
192.168.0.5
192.168.0.6`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);